Функция ИНДЕКС в Excel

Рассмотрим пример использования функции ИНДЕКС в Excel, которая возвращает значение или ссылку на значение из диапазона, заданного номерами строки и столбца.

Описание функции ИНДЕКС

Функция ИНДЕКС имеет 2 формы записи: форму массива и ссылочную. Давайте разберем в чем особенности каждой из них.

Форма массива

ИНДЕКС(массив; номер_строки; [номер_столбца])
Возвращает значение элемента таблицы или массива на пересечении конкретных строки и столбца, в данном диапазоне.

  • Массив (обязательный аргумент) — диапазон ячеек;
  • Номер строки (обязательный аргумент) — выбирает строку в массиве из которой будет возвращаться значение;
  • Номер столбца (необязательный аргумент) — выбирает столбец в массиве из которой будет возвращаться значение.

Ссылочная форма

ИНДЕКС(ссылка; номер_строки; [номер_столбца]; [номер_области])
Возвращает ссылку на ячейку на пересечении конкретных строки и столбца, в данном диапазоне.

  • Ссылка (обязательный аргумент) — ссылка на один или несколько диапазонов ячеек;
  • Номер строки (обязательный аргумент) — выбирает строку в указанном аргументе «ссылка» из которой будет возвращаться ссылка;
  • Номер столбца (необязательный аргумент) — выбирает столбец в указанном аргументе «ссылка» из которой будет возвращаться ссылка;
  • Номер области (необязательный аргумент) — номер диапазона в аргументе «ссылка».

Пример использования функции ИНДЕКС

Предположим у нас есть таблица данных с продуктами:

Таблица данных
Например, мы хотим получить значение из таблицы на пересечении строки №2 и столбца №3 (критерий 1 в нашем примере).
В качестве массива выбираем диапазон ячеек A2:C5, задаем номер строки как ячейку F3 (строка №2) и номер столбца как ячейку F4 (столбец №3), в качестве результата получаем «Груши»:

Пример №1 использования функции ИНДЕКС

Пример №1 использования функции ИНДЕКС

Также представим, что наша таблица состоит из областей и мы хотим получить значение из таблицы на пересечении строки №2 и столбца №1 из определенной области (критерий 2 в нашем примере).
В качестве ссылки выбираем 2 диапазона ячеек A2:C3 и A4:C5, задаем номер строки как ячейку F10 (строка №2), номер столбца как ячейку F11 (столбец №1) и номер области как ячейку F12 (область №1, т.е. диапазон A2:C3),в качестве результата получаем «Яблоки»:

Пример №2 использования функции ИНДЕКС

Пример №2 использования функции ИНДЕКС

Особенности функции ИНДЕКС

В качестве результата функции ИНДЕКС в Excel можно получить ссылку:

  • Если параметр номер_строки или номер_столбца равен 0 или отсутствует, то, например, результатом выполнения функции "=ИНДЕКС(A1:C6;0;2)" будет диапазон B2:B6, т.е. столбец №2 в диапазоне A1:C6.
  • Результат функции ИНДЕКС можно использовать в качестве ссылкы в других функциях. Например, результатов выполнения функции "=СУММ(C3:ИНДЕКС(A1:C6;6;3))" будет сумма значений из диапазона C3:C6, т.е. строка №6 и столбец №3 в диапазоне A1:C6 будет ячейка С6.

Удачи вам и до скорых встреч на страницах блога Tutorexcel.ru!

Поделиться с друзьями:
Поиск по сайту:

Добавить комментарий

Ваш e-mail не будет опубликован.

Читайте ранее:
Функция ПОИСКПОЗ в Excel

Рассмотрим пример использования функции ПОИСКПОЗ в Excel, которая производит поиск указанного элемента в диапазоне ячеек и возвращает его относительную позицию...

Закрыть